Banana Pi M2 Berry

Fragen & Tipps etc zur Software des BPI
RieJue
Beiträge: 20
Registriert: Sonntag 20. August 2017, 21:46
Deine Hardware: Banana Pi M2 Berry
Hat sich bedankt: 1 Mal
Status: Offline

Banana Pi M2 Berry

Beitragvon RieJue » Sonntag 20. August 2017, 22:01

Hallo,
ich habe mir einen Banana Pi M2 Berry gekauft und suche für dieses Teil ein Betriebssystem. Von BPI, Banana-PI.org habe ich mir das Image „2017-05-25-raspbian-jessie-preview3-bpi-m2u-sd-emmc.img.zip“ heruntergeladen. Leider funktioniert es nicht mit dem Banana Pi. Vielleicht kann mir jemand einen Hinweis geben, wo ich ein funktionsfähiges System finden kann.
Grüße Jürgen Rieger

Benutzeravatar
Wolf2000
Beiträge: 625
Registriert: Samstag 19. September 2015, 17:41
Deine Hardware: Banana Pi | R1 | M3 | M2U | M2Berry
Hat sich bedankt: 48 Mal
Danksagung erhalten: 52 Mal
Kontaktdaten:
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon Wolf2000 » Sonntag 20. August 2017, 22:20

Hi du warst schnell hier.
Das img was du runtergeladen hast sollte funktionieren!
Hast du es einpackt und mit dem Win32DiskImager auf die SD geschrieben.
Du brauchst auch eine gute Stromversorgung 2-2.5Amper, was auch noch wichtig ist sind Kühl Körper weil das Board sehr Heiss wird 70°C.
Gruß Wolf2000
Gebt Euer Wissen weiter :ugeek:
BananaPi /Armbian 4.5- 3.4.109 / Openmediavault 2.x
BananaPi /Armbian Kernel 4.10.12 / Openmediavault 3.x (Test)
BananaPi/ Bananian 15.04 / Openmediavault 2.x
Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)​​

https://github.com/Wolf2000Pi
https://discord.gg/u8HzwhU

RieJue
Beiträge: 20
Registriert: Sonntag 20. August 2017, 21:46
Deine Hardware: Banana Pi M2 Berry
Hat sich bedankt: 1 Mal
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon RieJue » Montag 21. August 2017, 21:01

Hallo Wolfgang,
vielen Dank für deine Nachricht. Schön, dass wir uns in Deutsch unterhalten können. Ich habe alles so gemacht wie du es mir empfohlen hast. Ich habe ein Netzteil mit 3Amp an den Banana Pi angeschlossen. Im Augenblick habe ich folgende Situation:
Die grüne LED am Banana Pi leuchtet nach dem Anlegen der Spannung auf Dauer für ca. 10 Sek. Dann beginnt sie zu blinken, als ob der Banana in einer Endlosschleife hängen bleibt. Irgendetwas ist an dem heruntergeladenen IMG nicht in Ordnung, oder das IMG wird nicht korrekt auf die SD-Karte geschrieben. Ich verstehe das nicht. Ich weiß auch nicht wie ich weiter komme. Ich habe schon X-Download Versuche durchgeführt, alle ohne Erfolg.
Grüße Jürgen

Benutzeravatar
Wolf2000
Beiträge: 625
Registriert: Samstag 19. September 2015, 17:41
Deine Hardware: Banana Pi | R1 | M3 | M2U | M2Berry
Hat sich bedankt: 48 Mal
Danksagung erhalten: 52 Mal
Kontaktdaten:
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon Wolf2000 » Montag 21. August 2017, 21:18

Hi
Hast du schon andere karten versucht
und hast du die Karten Formatiert? viewtopic.php?f=9&t=167
Hast einen Monitor angeschlossen.
Entferne alle Festplatten falls vorhanden.
Das Blinken der grünen Led ist bei mir gleichmäßig!
Gruß Wolf2000
Gebt Euer Wissen weiter :ugeek:
BananaPi /Armbian 4.5- 3.4.109 / Openmediavault 2.x
BananaPi /Armbian Kernel 4.10.12 / Openmediavault 3.x (Test)
BananaPi/ Bananian 15.04 / Openmediavault 2.x
Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)​​

https://github.com/Wolf2000Pi
https://discord.gg/u8HzwhU

RieJue
Beiträge: 20
Registriert: Sonntag 20. August 2017, 21:46
Deine Hardware: Banana Pi M2 Berry
Hat sich bedankt: 1 Mal
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon RieJue » Dienstag 22. August 2017, 22:45

Hallo Wolfgang,
vielen Dank, dass Du mir hilfst.
Alles dies wie du es aufgeführt hast habe ich schon X-Mal gemacht. Ich verwende genau die selben Tools (Win32Diskimager, SD-Formatter). Damit habe ich meine ganzen Raspberry Pis ohne Probleme zum Laufen gebracht.

Nur diesmal komme ich einfach nicht zum Ziel. Ich habe einen Bildschirm (HDMI) angeschlossen. Ich verwende ihn auch bei meinen Raspberrys. Der Bildschirm zuckt immerzu und es kommt nach jeder 2maligen Blinkpause die Meldung:
"Kein Bildschirmsignal".
Ich habe mal einen kleinen Film aufgenommen um das blinken der LED wieder zu geben. Ich versuche ihn hochzuladen.
Wäre es möglich von dir ein Image zu bekommen? Oder einen Link von dem du dein Image heruntergeladen hast?
Offensichtlich funktioniert der Banana Pi mit irgend einem Betriebssystem. Ich frage mich trotzdem, ob jemals jemand einen Banana Pi M2 Berry zu Laufen gebracht hat.
Grüße Jürgen

Benutzeravatar
Wolf2000
Beiträge: 625
Registriert: Samstag 19. September 2015, 17:41
Deine Hardware: Banana Pi | R1 | M3 | M2U | M2Berry
Hat sich bedankt: 48 Mal
Danksagung erhalten: 52 Mal
Kontaktdaten:
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon Wolf2000 » Mittwoch 23. August 2017, 02:33

Hallo Jürgen
Ich habe ein Problem entdeckt das sich die geschrieben SD-Karten sich nicht mehr Formatieren lassen.
Wenn es funktioniert sag ich es dir.
Gruß Wolf2000
Gebt Euer Wissen weiter :ugeek:
BananaPi /Armbian 4.5- 3.4.109 / Openmediavault 2.x
BananaPi /Armbian Kernel 4.10.12 / Openmediavault 3.x (Test)
BananaPi/ Bananian 15.04 / Openmediavault 2.x
Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)​​

https://github.com/Wolf2000Pi
https://discord.gg/u8HzwhU

RieJue
Beiträge: 20
Registriert: Sonntag 20. August 2017, 21:46
Deine Hardware: Banana Pi M2 Berry
Hat sich bedankt: 1 Mal
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon RieJue » Mittwoch 23. August 2017, 11:19

Hallo Wolfgang,
vielen Dank für die Nachricht.
Komisch das mit dem formatieren. Ich verwende die SD-Karten u. a. für meine Raspberrys und für die funktionieren "wieder formatierte" SD-Karten.
Ich habe übrigens das Video das ich im letzten Beitrag hochladen wollte auf meine Cload hochgeladen. Von dort kannst du es per unten aufgeführtem Link herunterladen und mit dem VLC anschauen.
https://www.magentacloud.de/lnk/vBgiiDZR
Ich bin gespannt was bei deiner Vermutung herauskommt.
Grüße Jürgen

RieJue
Beiträge: 20
Registriert: Sonntag 20. August 2017, 21:46
Deine Hardware: Banana Pi M2 Berry
Hat sich bedankt: 1 Mal
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon RieJue » Mittwoch 23. August 2017, 14:06

Hallo Wolfgang,
nachdem du mir das mit dem Probleme beim zweiten Mal verwenden der SD-Karte geschrieben hast, habe ich mir Gedanken gemacht über die bisher generierten SD-Karten. Ich habe festgestellt, dass die SD-Karten 2 primäre Partitionen besitzen. Bei mir D: und G:. Unter Linux sehe ich eine Partition sda1 und sda2. sda2 hat 7GB mit noch weiteren sekundären Partitionen. sda1 hat eine Partition von 255MB. Macht insgesamt 7,...GB. Ich verwende aber eine 32GB SD-Karte der Rest ist ungenutzt und kann auch nicht verwendet werden. Die SD-Karte ist so unlogisch aufgeteilt, dass 20GB verschenkt werden. Welche Logik dahinter steckt weiß vermutlich niemand. Ich habe auch festgestellt, dass ich unter Linux die SD-Karte nicht neu anlegen kann. Die Partitionen lassen sich nicht löschen. Das gelingt mir nur unter DOS. Das Image das in meiner Nachricht zuvor mit dem komischen Bootverhalten beschrieben wurde habe ich unter Linux heruntergeladen, dann in 3GB Teile aufgeteilt, weil Linux bei Dateien >4GB die Verarbeitung verweigert hat und nach Win 10 per USB-Stick übertragen. Dort habe ich die 3 Teile wieder verschmolzen und auf die SD-Karte mit WIN32Diskmanager gebrannt.

In einem weiteren Versuch habe ich eine SD-Karte unter Linux gebrannt. Die SD-Karte hatte nur eine Partition mit 29GB und war nicht lesbar, sowohl unter Windows als auch unter Linux. Ob und was auf die SD-Karte beim Erstellen geschrieben wurde weiß ich nicht.

Irgendwie ist das alles sehr mysteriös und unlogisch.

Schade, dass sich der Autor der Images zu nicht diesem Verhalten äußert.

Grüße Jürgen

Benutzeravatar
Wolf2000
Beiträge: 625
Registriert: Samstag 19. September 2015, 17:41
Deine Hardware: Banana Pi | R1 | M3 | M2U | M2Berry
Hat sich bedankt: 48 Mal
Danksagung erhalten: 52 Mal
Kontaktdaten:
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon Wolf2000 » Mittwoch 23. August 2017, 18:16

Diese Image sind gerechnet für 8G SD-Karten die kann man später Expandieren.

Ich habe auf deinen Video gesehen das du deine Spannung-Versorgung über GPIO hast, das ist nicht so eine gute Idee, der GPIO-Ports sind nicht ausgelegt für so eine hohe last. Verwende bitte denn Micro-USB!
Gruß Wolf2000
Gebt Euer Wissen weiter :ugeek:
BananaPi /Armbian 4.5- 3.4.109 / Openmediavault 2.x
BananaPi /Armbian Kernel 4.10.12 / Openmediavault 3.x (Test)
BananaPi/ Bananian 15.04 / Openmediavault 2.x
Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)​​

https://github.com/Wolf2000Pi
https://discord.gg/u8HzwhU

RieJue
Beiträge: 20
Registriert: Sonntag 20. August 2017, 21:46
Deine Hardware: Banana Pi M2 Berry
Hat sich bedankt: 1 Mal
Status: Offline

Re: Banana Pi M2 Berry

Beitragvon RieJue » Donnerstag 24. August 2017, 21:53

Hallo Wolfgang,
ich habe das zuerst anders gehabt, habe mir dann aufgrund der Stromaufnahme von 2Amp und mehr mal das niedliche Micro USB Steckerchen angeschaut und bin zu dem Ergebnis gekommen, dass die Stiftleiste eine höhere Belastung verträgt, als der USB-Microstecker. Nachfolgend die technischen Daten eines USB Microsteckers:
Current - Maximum per Contact 1.8A, 1.0A.
Noch einmal, die Stiftleiste kann mit Sicherheit mehr an Strom vertragen, zumal ich an ihr mehrere Anschlüsse habe.

Zu dem Image,
Bedeuted das 32GB SD-Karten mit dem Image das ich heruntergeladen habe funktionieren nicht auf dem Babana Pi?
Grüße Jürgen


Zurück zu „Software“

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 3 Gäste