Bananian + acpid Backup Accu

Benutzeravatar
KrümelMonster
Beiträge: 245
Registriert: Dienstag 24. Mai 2016, 19:19
Deine Hardware: Banana Pro, Raspberry Pi B+, Raspberry Pi 2, Arduino Uno
Hat sich bedankt: 13 Mal
Danksagung erhalten: 44 Mal
Status: Offline

Re: Bananian + acpid Backup Accu

Beitragvon KrümelMonster » Donnerstag 16. Februar 2017, 20:30

Wie gesagt, ist ein Bug in Bananian. Armbian versuchen oder es eben so machen.
Discord Forenchat kostenlos, keine Registrierung, ohne Installation direkt im Browser

saarbrigger128
Beiträge: 14
Registriert: Dienstag 14. Februar 2017, 01:06
Deine Hardware: Banana Pro (Lemaker)
war mal OS Bananian (Jessie) Vers 3.4.113-bananian
jetzt armbian 5.25 Bananapipro Debian_jessie_next 4.9.12-sunxi #4 SMP Thu Feb 23 19:46:51

Raspberry A+,B+,Zero,2B,3B mit raspbian jessy
Hat sich bedankt: 3 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Bananian + acpid Backup Accu

Beitragvon saarbrigger128 » Freitag 17. Februar 2017, 00:15

...ich benutze nur den normalen Power Eingang und den Accu-Anschluss...
...die angeschlossene CR2032 hat keinen Einfluss...

Stromlauf zu finden bei http://www.lemaker.org

Banana Pro => http://Mirror.lemaker.org/A20_banana_v15_150304_2.pdf
hier ist auch ein Blockschaltbild dabei

Banana Pi => http://Mirror.lemaker.org/Banana%20Pi%20Schematic.pdf

Im Stromlauf PDF kann man wunderbar suchen..

PMU AXP209 => http://linux-sunxi.org/images/8/89/AXP2 ... v1.0en.pdf

Wolf2000 hat wahrscheinlich recht...

Vom AXP209 werden die Spg.-Regler für VCC-3V und VCC-5V über das Signal EXTEN abgeschaltet.
Das Signal hab ich über die I2C-Bus Reg12h abgeschaltet.
(ok damit hab ich das Board kalt ausgeschaltet. RT-LED aus, hängt an 3,3V)

Die 3,3V und 5V kann man an der GPIO-Leiste(Seite 10) messen.
Die Spg.-Regler sind auf Seite 10 zu finden

Die 3,3V von U8 sind weg
Die 5,0V von U9 sind dann immer noch 4,7V und kommen vom ACCU
zieht man den ab dann fällt die 5V Spg.
Alles an der GPIO-Leiste gemessen.

Das heißt für mich, endweder stimmt der Stromlauf nicht oder
ein Low-Pegel liegt NICHT am 5V-Regler U9 an.

Und das muss eben so hinnehmen.

Ist eigentlich schade der Banana bietet so viel...
Aber alles nicht richtig rund...

Danke für eure Hinweise

VG SaarBrigger

PS: sorry, wenn ich immer so ausfühlich schreibe, eher in den Foren nicht üblich...

saarbrigger128
Beiträge: 14
Registriert: Dienstag 14. Februar 2017, 01:06
Deine Hardware: Banana Pro (Lemaker)
war mal OS Bananian (Jessie) Vers 3.4.113-bananian
jetzt armbian 5.25 Bananapipro Debian_jessie_next 4.9.12-sunxi #4 SMP Thu Feb 23 19:46:51

Raspberry A+,B+,Zero,2B,3B mit raspbian jessy
Hat sich bedankt: 3 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Bananian + acpid Backup Accu

Beitragvon saarbrigger128 » Samstag 25. Februar 2017, 02:56

Danke KrümelMonster,

Super, mit armbian geht es...

uname -a
Linux bananapipro 4.9.12-sunxi #4 SMP Thu Feb 23 19:46:51 CET 2017 armv7l GNU/Linux

In der Version ist der axp209 unterstützt.
Nachteil: der Ladestrom für den Accu ist auf 1200mA eingestellt.

Bisher nicht weiteres installiert. (erkennen das Netzteil ausgeschaltet ist und den SBC runterfährt...)
Also kein acpid installiert...

a)
Netzteil aus... SBC läuft über Accu weiter
Power-Button gedrückt... SBC mach shutdown

Man kann auch mit Accu, ohne Netzteil wieder über Powerbutton wieder einschalten

b)
Netzteil eingeschaltet, Accu angeschlossen
Power-Button gedrückt => SBC fährt runter und macht kein reboot.
Auch einschalten geht über Power-Button

VG SaarBrigger

PS: mein BananaPro(Lemaker) ist schon 1-Jahr alt
Inzwischen sehen die Bilder in den Shops etwas anders aus.


Zurück zu „Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast