zwei interne Netzwerke

tinti
Beiträge: 6
Registriert: Donnerstag 5. Januar 2017, 12:59
Deine Hardware: Banana Pi R1
Status: Offline

zwei interne Netzwerke

Beitragvon tinti » Mittwoch 8. Februar 2017, 00:03

Hallo Leute,

ich habe ein Banana Pi R1 und möchte mit
OpenWRT zwei interne Netzwerke einrichten.
Eines mit 192.168.x.x und eines mit 10.0.x.x.
Es sollte so sein dass ich auf beide Netze
Zugriff habe. Also von 192.168.x.x auf
10.0.x.x und umgekehrt. Im Internet habe ich
leider keine Anleitung gefunden die das
beschreiben würde. Alle meine Versuche
schlugen fehl. Editiert habe ich die
"/etc/config/network" Datei, weis aber nicht
ob ich das korrekt gemacht habe.
Ich hoffe Ihr könnt mir weiterhelfen.
Hier die Datei.


config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'x:x:x:x::/48'

config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'

config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6'

config switch 'eth0'
option enable '1'
option enable_vlan '1'
option reset '1'

config switch_vlan
option device 'eth0'
option ports '0 1 2 4 8t'
option vlan '1'

config switch_vlan
option device 'eth0'
option vlan '2'
option ports '3 8t'


config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option delegate '0'
option ipaddr '192.168.x.x'

config interface 'lan10'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '10.0.x.x'
option netmask '255.255.255.0'

vielen Dank im Voraus

Benutzeravatar
Wolf2000
Beiträge: 603
Registriert: Samstag 19. September 2015, 17:41
Deine Hardware: Banana Pi | R1 | M3 | M2U | M2Berry
Hat sich bedankt: 42 Mal
Danksagung erhalten: 50 Mal
Kontaktdaten:
Status: Offline

Re: zwei interne Netzwerke

Beitragvon Wolf2000 » Mittwoch 8. Februar 2017, 02:08

Ich habe mit dem OpenWRT schon lange nicht mehr gearbeitet.
Das 'eth0.2' sagt mir nichts, normalerweise sin da die vlan's die musste man auf static stellen.
Du müsstest eine Bridge erteilen in etwa:
auto br0
iface br0 inet static
bridge_ports eth0.102 eth0.102 wlan0
address 192.168.9.2
network 192.168.9.0
netmask 255.255.255.0
Gruß Wolf2000
Gebt Euer Wissen weiter :ugeek:
BananaPi /Armbian 4.5- 3.4.109 / Openmediavault 2.x
BananaPi /Armbian Kernel 4.10.12 / Openmediavault 3.x (Test)
BananaPi/ Bananian 15.04 / Openmediavault 2.x
Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)​​

https://github.com/Wolf2000Pi
https://discord.gg/u8HzwhU


Zurück zu „OpenWRT“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast